Tablet Sets Hardware Clock to Incorrect Time

Tablet Sets Hardware Clock to Incorrect Time

Tablet Sets Hardware Clock to Incorrect Time

Context

DLI and DT Research tablets running OS image 5.0.4 - 5.3.4.

Symptoms

  1. System time is off by 5-8 hours.

Diagnosis

  1. Confirm that the problem occurs on a tablet running OS image version 5.0.4 - 5.3.4.

    # cat /etc/FC-release
     
  2. Check the system clock against the hardware clock and verify that these two times are different.

    # date && hwclock
     
  3. Check the hardware clock time logged by the fullcount-hwclock service and compare it to the system time logged at the beginning of the message. Scroll down to the most recent messages.

    # journalctl SYSLOG_IDENTIFIER=fullcount-hwclock | less

    Feb 26 10:01:16 042652002.fullcount.net fullcount-hwclock[10892]: get_hardware_clock_time(): Reading current time from hardware clock.
    Feb 26 10:01:17 042652002.fullcount.net fullcount-hwclock[10922]: get_hardware_clock_time(): Current hardware clock time is: Mon Feb 26 16:01:17 2018 -0.380407 seconds
     
  4. Check the system time at last boot and verify that it is incorrect. You may have to reboot once to get a baseline system time if you are unsure of when the tablet was last booted.

    # journalctl -b

    The message on the 2nd line will show a date and timestamp for the system clock that was initially pulled from the hardware clock, and before NTP loads to fix the system time.
     
  5. Confirm that UTC is currently set on the tablet in yast timezone. An “X” will appear in the checkbox that says “Hardware Clock Set to UTC.”

    # yast timezone

Resolution

  1. Uncheck checkbox that says “Hardware Clock Set to UTC” in yast timezone and press “OK”.

    # yast timezone
     
  2. When returned to the command line, restart NTP and check to make sure the system time is accurate.

    # systemctl stop ntp
    # systemctl start ntp
    # date

     
  3. Update the hardware clock from the system clock time.

    # hwclock --systohc --noadjfile --localtime
     
  4. 4. Compare the system clock to the hardware clock and verify that they are now accurate.

    # date && hwclock
     
  5. Reboot the tablet (it may reboot a second time on its own).
     
  6. Check to see if tablet booted with the correct system time by looking at the date and timestamp that appears at the beginning of the first few journal messages.

    # journalctl -b

 


    • Related Articles

    • FullCount Hardware Information - Vendor Part Numbers

      FullCount Hardware Information - Vendor Part Numbers Lang Technologies, Inc. DBA FullCount ScanSource Account number is 1000020733. ID Common Name Vendor Manufacturer Vendor Part Number(s) Vendor Description Lead Time/shipping notes Other Notes 1 ...
    • FullCount Hardware Spec Sheets

      FullCount Hardware Spec Sheets Manufacturer spec sheets for all FullCount hardware can be found on the J: Drive by copying and pasting the link below in your local File Explorer. The list that follows shows the name of each device's file and a link ...
    • FullCount Hardware Links

      Terminal: Pioneer terminal - 15" Cyprus (All-in-one or Wall-mounted): http://www.pioneersolution.com/all-in-one/15-cyprus/ Printers: Kitchen Requisition: Epson TM-U220 Kitchen Requisition printer (No updated version pictures): ...
    • Andorid Tablet Evaluation Process

      Current Android Offerings: https://kb.fullcount.net/documentation/fullcount-hardware-links Check to see if any of our current offerings have been end-of-lifed using https://endoflife.date/samsung-mobile. 1. Go through our list of approved android ...
    • Hardware Vendor Contacts and Ordering Processes

      Hardware Vendor Contacts and Ordering Processes ScanSource Main Contact: Logan Garner - Account Manager - logan.garner@scansource.com - Mobile/Direct: 706-372-3144 | Office: 864-286-4463 (backup) Bonner Wadsworth - Account Manager - ...